header logo

Go Back   Checkmate Community Boating Forums > Checkmate Discussion Forums > Powerplant Technical Discussions > Engine Technical Discussion
Portal Home Register Blogs FAQ Calendar Mark Forums Read

Engine Technical Discussion This is our non outboard engine related technical discussion forum. If your boat is powered by a Inboard/Outboard, Jet drive, V-drive, or even something else, then this is the forum for you! Topics include engine repair and maintenance, modifications, drives and gearcases, electrical and electronics, etc. For technical assistance related to outboards, please use our outboard tech forum.

Main Menu
Module Jump:
Google Search
Google
Latest Poll
October 2018's Boat of the Month Vote!
This poll is closed
I vote for "Redboat's" Senator! 0 0%
I vote for "JupiterPulsare's" Starflite! 5 36%
I vote for "Chrisg82's" Enchanter Jet! 3 21%
I vote for "knarloid's" group shot! 6 43%
Voters: 14 100%
Notices

Welcome to the Checkmate Community Forums

Reply
 
Thread Tools Display Modes
Old 09-18-2018, 08:15 PM   #1
tburn
Playmate
 
tburn's Avatar
 
Join Date: Jun 2009
Location: Waterboro,Maine
Posts: 56
Thanks: 0
Thanked 14 Times in 4 Posts
Rep Power: 115
tburn is on a distinguished road
Model Owned: Exciter I/O

Default 1984 Exciter i/o 350

So I haven't used my boat in over a month. Went to take it for a spin and it started right up and stalled because I didn't catch it to keep it running, anyway so when that happens it floods pretty easy so I cranked it wide open usually starts right up once it dries out the throat but this time the batteries dragged right down and almost seemed like it was hydro locked. Brought it up to the garage charged the batteries and there is some kind of intermittent draw that pulls the volt meter right down to 10 volts without even cranking and then pops right back up eventually to 12.6. So I can make it do it by leaving the key on and shutting the battery switch on and off. So when it is in 10 volt mode I cut the purple wire coming from the Thunderbolt amplifier to the coil and the volts went right back up to 12.6. would this mean the amplifier is bad? I also had the sensor in the distributor unhooked in case that was acting up. Also when the voltage drop happens and stays that way for a few minutes while testing things the coil and amplifier both get warm. I have had it running since then and runs fine but when the voltage drops the engine stalls like shutting the key off. Thanks for any help
__________________
EXCITER 350
tburn is offline   Reply With Quote
Old 09-18-2018, 09:06 PM   #2
tburn
Playmate
 
tburn's Avatar
 
Join Date: Jun 2009
Location: Waterboro,Maine
Posts: 56
Thanks: 0
Thanked 14 Times in 4 Posts
Rep Power: 115
tburn is on a distinguished road
Model Owned: Exciter I/O

Default Exciter voltage problem

Also wanted to add, the alternator seems to be putting out fine while its running, keyswitch is new, I dont see any wiring problems. Just this weird intermittent voltage drop.
__________________
EXCITER 350
tburn is offline   Reply With Quote
Old 09-22-2018, 12:26 PM   #3
PA-Cougar
Enchanter
 
Join Date: Dec 2006
Location: Western Pennsylvania
Age: 66
Posts: 194
Thanks: 2
Thanked 37 Times in 28 Posts
Rep Power: 145
PA-Cougar is on a distinguished road
Model Owned: Stingray 230SX 502-MAG EFI

Default

I would check the ALT voltage at the stud on back of ALT which should be close to 13.6V. then at battery... they should be about the same.
__________________



PA-Cougar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"For Sale" Checkmate Exciter - 1984 Basspikr Checkmate Listings 4 03-28-2015 02:23 PM
1984 Exciter prop tburn Props, Setups & Rigging 9 06-25-2013 10:31 PM
1984 Exciter restoration almost complete jamestorque9 Restoration Discussions 10 07-17-2012 09:40 PM
1984 Exciter 260 I/O tburn Restoration Discussions 13 06-01-2012 09:23 AM
1984 exciter 19 235 johnson Drew Virnelson Checkmate Listings 11 10-25-2005 09:09 AM


All times are GMT -4. The time now is 02:36 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2002-2018 Checkmate-Boats.com & Whitecap Enterprises Corp. All Rights Reserved.
Images & Content are Copyright material and may not used without prior written permission.